Protocol Overhead

Protocol Overhead

How fast can you really go using a given media and protocol stack? We examine how much bandwidth is left for applications.

Ethernet

Ethernet frame format:

  • 6 byte dest addr
  • 6 byte src addr
  • [4 byte optional 802.1q VLAN Tag]
  • 2 byte length/type
  • 46-1500 byte data (payload)
  • 4 byte CRC
Ethernet overhead bytes:
  12 gap + 8 preamble + 14 header + 4 trailer = 38 bytes/packet w/o 802.1q
  12 gap + 8 preamble + 18 header + 4 trailer = 42 bytes/packet with 802.1q

Ethernet Payload data rates are thus:
  1500/(38+1500) = 97.5293 %   w/o 802.1q tags
  1500/(42+1500) = 97.2763 %   with 802.1q tags
  9000/(38+9000) = 99.5796 %   jumbo w/o 802.1q tags
  9000/(42+9000) = 99.5355 %   jumbo with 802.1q tags

TCP over Ethernet:
 Assuming no header compression (e.g. not PPP)
 Add 20 IPv4 header or 40 IPv6 header (no options)
 Add 20 TCP header
 Add 12 bytes optional TCP timestamps
 Max TCP Payload data rates over ethernet are thus:
  (1500-40)/(38+1500) = 94.9285 %  IPv4, minimal headers
  (1500-52)/(38+1500) = 94.1482 %  IPv4, TCP timestamps
  (1500-52)/(42+1500) = 93.9040 %  802.1q, IPv4, TCP timestamps
  (1500-60)/(38+1500) = 93.6281 %  IPv6, minimal headers
  (1500-72)/(38+1500) = 92.8479 %  IPv6, TCP timestamps
  (1500-72)/(42+1500) = 92.6070 %  802.1q, IPv6, ICP timestamps
  (9000-40)/(38+9000) = 99.1370 %  Jumbo IPv4, minimal headers
  (9000-52)/(38+9000) = 99.0042 %  Jumbo IPv4, TCP timestamps
  (9000-52)/(42+9000) = 98.9604 %  Jumbo 802.1q, IPv4, TCP timestamps
  (9000-60)/(38+9000) = 98.9157 %  Jumbo IPv6, minimal headers
  (9000-72)/(38+9000) = 98.7829 %  Jumbo IPv6, TCP timestamps
  (9000-72)/(42+9000) = 98.7392 %  Jumbo 802.1q, IPv6, ICP timestamps

UDP over Ethernet:
 Add 20 IPv4 header or 40 IPv6 header (no options)
 Add 8 UDP header
 Max UDP Payload data rates over ethernet are thus:
  (1500-28)/(38+1500) = 95.7087 %  IPv4
  (1500-28)/(42+1500) = 95.4604 %  802.1q, IPv4
  (1500-48)/(38+1500) = 94.4083 %  IPv6
  (1500-48)/(42+1500) = 94.1634 %  802.1q, IPv6
  (9000-28)/(38+9000) = 99.2697 %  Jumbo IPv4
  (9000-28)/(42+9000) = 99.2258 %  Jumbo 802.1q, IPv4
  (9000-48)/(38+9000) = 99.0485 %  Jumbo IPv6
  (9000-48)/(42+9000) = 99.0046 %  Jumbo 802.1q, IPv6

An excellent source of ethernet information is Charles Spurgeon’s Ethernet Web Site.

Notes:

  1. 48-bit (6 byte) ethernet address have a 24-bit “Organizationally Unique Identifier” (OUI) assigned by IEEE + a 24-bit number assigned by the vendor.
  2. The minimum ethernet payload (data field) is 46 bytes which makes a 64 byte ethernet packet including header and CRC.
  3. The maximum ethernet payload (data field) is 1500 bytes which makes a 1518 byte ethernet packet including header and CRC. When 802.1q added an optional 4-byte VLAN Tag Header, they extended the allowed maximum frame size to 1522 bytes (22 byte header+CRC).
  4. The bit speed of 100 Mbps ethernet on the wire/fiber is actually 125 Mbps due to 4B/5B encoding. Every four data bits gets mapped to one of 16 5-bit symbols. This leaves 16 non-data symbols. This encoding came from FDDI.
  5. The original Ethernet II spec had a two byte type field which 802.3 changed to a length field, and later a length/type field depending on use: values 1536 and over are types, under 1536 lengths.
  6. The Interframe Gap (IFG) between ethernet frames is 96 bit times (= 12 bytes) for all speeds of ethernet (at least up to 10G). This gap is sometimes reduced by repeaters due to clock differences and could be as small as 5 bytes on reception. Also, some NICs allow it to be reduced, but this is not recommended.

Gigabit Ethernet with Jumbo Frames

Gigabit ethernet is exactly 10 times faster than 100 Mbps ethernet, so for standard 1500 byte frames, the numbers above all apply, multiplied by 10 (for 10GE, multiple by 100). Many GigE devices however allow “jumbo frames” larger than 1500 bytes. The most common figure being 9000 bytes. For 9000 byte jumbo frames, potential GigE throughput becomes (from Bill Fink, the author of nuttcp):

Theoretical maximum TCP throughput on GigE using jumbo frames:

	(9000-20-20-12)/(9000+14+4+7+1+12)*1000000000/1000000 = 990.042 Mbps
	  |   |  |  |     |   |  | | | |       |         |
	 MTU  |  |  |    MTU  |  | | | |      GigE      Mbps
	      |  |  |         |  | | | |
	     IP  |  |  Ethernet  | | | |      InterFrame Gap (IFG), aka
	  Header |  |    Header  | | | |      InterPacket Gap (IPG), is
		 |  |            | | | |      a minimum of 96 bit times
	       TCP  |          FCS | | |      from the last bit of the
	    Header  |              | | |      FCS to the first bit of
		    |       Preamble | |      the preamble
		  TCP                | |
	      Options            Start |
	  (Timestamp)            Frame |
			     Delimiter |
				 (SFD) |
				       |
				   Inter
				   Frame
				     Gap
				   (IFG)

Theoretical maximum UDP throughput on GigE using jumbo frames:

	(9000-20-8)/(9000+14+4+7+1+12)*1000000000/1000000 = 992.697 Mbps

Theoretical maximum TCP throughput on GigE without using jumbo frames:

	(1500-20-20-12)/(1500+14+4+7+1+12)*1000000000/1000000 = 941.482 Mbps

Theoretical maximum UDP throughput on GigE without using jumbo frames:

	(1500-20-8)/(1500+14+4+7+1+12)*1000000000/1000000 = 957.087 Mbps

ATM

An excellent paper on ATM overhead was written by John Cavanaugh of MSC. A postscript copy can be found here. Based on that paper:

  -------------------------- DS3 ------------------------------
  Line Rate           44.736 Mbps
  PLCP Payload        40.704                       (avail to ATM)
  ATM Payload         36.864                       (avail to AAL)
                     MTU=576  MTU=9180 MTU=65527
  AAL5 Payload        34.501   36.752   36.845     (avail to LLC/SNAP)
  LLC/SNAP Payload    34.028   36.720   36.841     (avail to IP)
  IP Payload          32.847   36.640   36.830     (avail to transport)
    UDP Payload       32.374   36.608   36.825     (avail to application)
    TCP Payload       31.665   36.560   36.818     (avail to application)

  -------------------------- OC-3c ------------------------------
  Line Rate           155.520 Mbps
  SONET Payload       149.760                      (avail to ATM)
  ATM Payload         135.632                      (avail to AAL)
                     MTU=576  MTU=9180 MTU=65527
  AAL5 Payload        126.937  135.220  135.563    (avail to LLC/SNAP)
  LLC/SNAP Payload    125.198  135.102  135.547    (avail to IP)
  IP Payload          120.851  134.808  135.506    (avail to transport)
    UDP Payload       119.112  134.690  135.489    (avail to application)
    TCP Payload       116.504  134.513  135.464    (avail to application)

  -------------------------- OC-12c -----------------------------
  Line Rate           622.080 Mbps
  SONET Payload       600.768                      (avail to ATM)
  ATM Payload         544.092                      (avail to AAL)
                     MTU=576  MTU=9180 MTU=65527
  AAL5 Payload        509.214  542.439  543.818    (avail to LLC/SNAP)
  LLC/SNAP Payload    502.239  541.966  543.752    (avail to IP)
  IP Payload          484.800  540.786  543.586    (avail to transport)
    UDP Payload       477.824  540.313  543.519    (avail to application)
    TCP Payload       467.361  539.605  543.420    (avail to application)

Notes:

  1. DS3 and SONET frames are 125 usec long (8000/sec).
  2. PLCP packs 12 ATM cells per DS3 frame, for 96 kc/s (8000×12).
  3. An STS-3c frame (OC3c) is 2430 bytes long (270 bytes x 9 rows), 90 of which are consumed by SONET overhead (9 bytes x 9 rows section and line overhead and 1 byte x 9 rows path overhead), 2340 bytes are payload (260 bytes x 9 rows). The payload is called the Synchronous Payload Envelope (SPE).
  4. An STS-12c frame (OC12c) is 9720 bytes long, 333 of which are SONET overhead, 9387 bytes are payload (SPE). Note that this is slightly larger than four STS-3c SPE’s (4×2340=9360), the advantage of “concatenated” OC12c vs. OC12.
  5. ATM cells are 53 bytes long: 5 header and 48 payload.
  6. AAL5 adds an 8 byte trailer in the last 8 bytes of the last cell, padding in front of the trailer if necessary. This results in 0-47 bytes of padding in an AAL5 frame. In the worse case, you have seven bytes of padding in one cell, and 40 bytes of padding plus the 8 byte AAL5 trailer in the following cell.
  7. RFC1483 defines two types of protocol encapsulation in AAL5
    • LLC/SNAP – adds an 8 byte header containing LLC (3 bytes), OUI (3 bytes), and PID/EtherType (2 bytes)
    • VC-mux – adds no additional bytes by sending only a single protocol type per VC
  8. IPv4 usually adds 20 bytes. IPv6 would add 40 bytes. Plus any options but assumed zero here.
  9. UDP adds an 8 byte header. (ICMP is also an 8 byte header)
  10. TCP adds a 20 byte header plus any options. A common option on high performance flows is timestamps which consume an additional 12 bytes per packet.

On the physical layer (single pt-to-pt hop), one out of every 27 cells is an OAM cell. The above calculations don’t take that into account, but that’s another 3.7% reduction!

We should add calculations for ping packets and 1500 byte packets.

So what is the largest packet that we can fit in a single ATM cell? If you are using AAL5, you have a 40 byte payload to work with. For IPv4, you could have a 20 byte header + a 20 byte IP payload. A UDP or ICMP payload could be up to 12 bytes (both use 8 bytes after the IP header). So a “ping -s8” through “ping -s12” should fit in one ATM cell and still give you a round trip time.

 


Packet Over SONET (POS)

Packet over SONET (POS) uses PPP with HDLC to frame IP packets. These add a five byte header and a four byte trailer under normal circumstances. No padding is required, except for any possible idle time between packets. Byte stuffing is used (see notes below) which can expand the length of the POS frame.

       Flag Byte (0x7e)
       Address Byte (0xff = all stations)
       Control Byte (0x03 = Unnumbered Information)
          Protocol - 2 bytes, 1 byte if compressed      +
          Payload - 0-MRU bytes                         | PPP part
          Padding - 0+ bytes                            +
       Frame Check Sequence (FCS) - 4 bytes (2 in limited cases)
       Flag Byte (0x7e)
       [Interframe fill or next Address]

HDLC has no set frame size limit, nor does PPP specify the payload size, you just keep reading until you see a Flag byte. PPP however specifies that the Maximum Receive Unit (MRU) default is 1500 bytes and that other sizes can be negotiated using LCP. These LCP messages have a 16-bit length field, so a properly negotiated maximum payload would be 65535 bytes. [It would be possible to configure a sender/receiver pair to go beyond 65535 and simply not negotiate a size with LCP. No one does this however.]

Most POS hardware seems to have a 4470 or 9180 byte MRU. Some Cisco documentation says the MRU can only be set between 64 and 17940 (go figure), and recommends a setting of 1492. Juniper documentation says they support up to 65535. The RFC says you must be able to receive at least 1500 even if you set this lower.

So we get:

  -------------------------- OC-3c ------------------------------
  Line Rate           155.520 Mbps
  SONET Payload       149.760                      (avail to POS)
  POS Payload         *** to do ***                (avail to IP)
  etc.

  -------------------------- OC-12c -----------------------------
  Line Rate               622.080 Mbps
  SONET Payload           600.768                      (avail to POS)
                         MTU=1500   MTU=9000
  POS Payload (no stuff)  597.185    600.168           (avail to IP)  9 overhead
  POS Payload (rnd stuff) 592.583    595.520                          20.71875 overhead
  POS Payload (max stuff) 299.486    300.234                          1509 overhead

  ~TCP Payload w/ts rnd   572.040    592.079

Notes:

  1. Only one flag byte is required between frames, i.e. the flag byte that ends one frame can also begin the next.
  2. It is possible for the HDLC Address and Control fields to be “compressed”, i.e. non-existent. This is negotiated by PPP’s Link Control Protocol (LCP). The RFC’s however recommend that they be present on high speed links and POS.
  3. The protocol field can be compressed to one byte (negotiated by LCP), but this is also discouraged on high speed links and POS.
  4. IP -> PPP -> FCS generation -> Byte stuffing -> Scrambling -> SONET/SDH framing
  5. The Frame Check Sequence (FCS) for POS should be 32-bits. RFC2615 allows for 16-bits (the PPP default) only when required for backward compatibility, and only on OC3c. Even on OC3c 32-bit is recommended. The FCS length is configured, not negotiated. The FCS-32 uses the exponents x**0, 1, 2, 4, 5, 7, 8, 10, 11, 12, 16, 22, 23, 26, 32.
  6. Byte stuffing escapes any Flag (0x7e) and Escape (0x7d) bytes by inserting an Escape byte and xoring the original byte with 0x20. [PPP can also escape negotiated control characters but this is not used in POS.] Byte stuffing can at worse double the payload size (e.g. data of all 0x7e). For uniform random data one in every 128 bytes would be stuffed, for an overhead of 0.775%.
  7. The stuffed data is then scrambled with 1+x**43 (the same used for ATM) to prevent certain data patterns from interfering with SONET.

 

References:

  • RFC1661 The Point-to-Point Protocol (PPP), July 1994
  • RFC1662 PPP in HDLC-like Framing, July 1994
  • RFC2615 PPP over SONET/SDH, June 1999

 

POS with Frame Relay encapsulation

Frame Relay (FR) encapsulation can be used on POS instead of HDLC/PPP. There are not any RFC’s about Frame Relay over SONET, nor does the Multiprotocol over Frame Relay RFC1490 discuss SONET or POS, but Cisco starting doing this and others have followed.

References:

  • RFC2427 Multiprotocol Interconnect over Frame Relay, September 1998

Generic Framing Proceedure

A new way to do POS uses PPP over GFP-F (Generic Framing Proceedure, Framed) instead of HDLC. In both the HDLC and GFP-F cases, SONET / SDH VCAT (Virtual Concatenation) is used. GFP-F also allows Ethernet frames (100, GE and 10GE) and Resilient Packet Ring (RPR) frames to be sent over SONET/SDH VCAT. GFP can also map to G.709 (part of the Optical Transport Network (OTN) series).

A GFP User Frame:

  • 4 byte Core Header
    • 2 byte PDU Length Indicator (PLI)
    • 2 byte Core Header Error Control (cHEC)
  • Payload – up to 65535 bytes
    • Payload Header (4-64 bytes)
      • 2 byte Type
      • 2 byte tHEC
      • 0-60 byte Extension Header including an optional 2 byte eHEC at the end.
    • Payload (min of 1600 should be supported, larger by agreement)
    • Payload FCS (optional)

A PLI of 0-3 indicates a GFP control frame. cHEC is a CRC-16 that protects the core header only (single bit error correction, multi bit error detection).

References:

Multi Protocol Label Switching (MPLS)

Multi-Protocol Label Switching (MPLS) adds four bytes to every frame. As described in RFC3032 the 32-bit label includes:

 0                   1                   2                   3
 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ Label
|                Label                  | Exp |S|       TTL     | Stack
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ Entry

     Label:  Label Value, 20 bits
     Exp:    Experimental Use, 3 bits
     S:      Bottom of Stack, 1 bit
     TTL:    Time to Live, 8 bits

Serial Lines (T1,T3)

To do

  • DS-3 is specified as 44.736 Mbps +/- 20 parts per million (ppm). So one DS-3 can vary from another by up to 1789 bps.
  • Bit-stuffing is used to accommodate rate mismatches as you mux up the DS-n hierarchy.

P. Dykstra, phil@sd.wareonearth.com, March 2001, last update July 2011

Posted in Internet, Linux, 文摘 | Leave a comment

Fortinet NPU offloading tags

NPU offloading tag

NP1(FA1): 1
NP1(FA2): 2
NP2: 3
NP4: 4
XLR: 5
NPlite:6
XLP: 7
NP6: 8

Posted in Fortinet, 文摘 | Tagged , | Leave a comment

IPv6 automatic 6to4 Tunneling

# IPv6 automatic 6to4 Tunneling
# TOPOLOGY
# R1 is IPv4 only backbone, R2, R3 and R4 are all connected to R1 over Frame-Relay circuits

# Reference
1. IPv6 over IPv4 Tunneling, http://packetlife.net/blog/2010/mar/15/6to4-ipv6-tunneling/
2. IPv4 to IPv6 Conversion, https://www.ultratools.com/tools/ipv4toipv6

 

1. Configure IPv4 backbone for full connectivity;
# R1
configure terminal
interface Serial1/0
encapsulation frame-relay
no arp frame-relay
no frame-relay inverse-arp
no shutdown
end
show frame-relay pvc | in DLCI

configure terminal
interface Loopback0
ip address 172.28.0.1 255.255.255.255
interface Serial1/0.102 point-to-point
ip address 172.28.1.1 255.255.255.252
ip ospf network point-to-point
frame-relay interface-dlci 201
interface Serial1/0.103 point-to-point
ip address 172.28.1.5 255.255.255.252
ip ospf network point-to-point
frame-relay interface-dlci 301
interface Serial1/0.104 point-to-point
ip address 172.28.1.9 255.255.255.252
ip ospf network point-to-point
frame-relay interface-dlci 401
end

configure terminal
router ospf 100
router-id 172.28.0.1
log-adjacency-changes detail
network 172.28.0.1 0.0.0.0 area 0
network 172.28.1.1 0.0.0.0 area 0
network 172.28.1.5 0.0.0.0 area 0
network 172.28.1.9 0.0.0.0 area 0
end

# R2
configure terminal
interface Loopback0
ip address 172.28.0.2 255.255.255.255
interface Serial1/0.201 point-to-point
ip address 172.28.1.2 255.255.255.252
ip ospf network point-to-point
frame-relay interface-dlci 102
end

configure terminal
router ospf 100
router-id 172.28.0.2
log-adjacency-changes detail
network 172.28.0.2 0.0.0.0 area 0
network 172.28.1.2 0.0.0.0 area 0
end

# R3
configure terminal
interface Loopback0
ip address 172.28.0.3 255.255.255.255
interface Serial1/0.301 point-to-point
ip address 172.28.1.6 255.255.255.252
ip ospf network point-to-point
frame-relay interface-dlci 103
end

configure terminal
router ospf 100
router-id 172.28.0.3
log-adjacency-changes detail
network 172.28.0.3 0.0.0.0 area 0
network 172.28.1.6 0.0.0.0 area 0
end

# R4
configure terminal
interface Loopback0
ip address 172.28.0.4 255.255.255.255
interface Serial1/0.401 point-to-point
ip address 172.28.1.10 255.255.255.252
ip ospf network point-to-point
frame-relay interface-dlci 104
end

configure terminal
router ospf 100
router-id 172.28.0.4
log-adjacency-changes detail
network 172.28.0.4 0.0.0.0 area 0
network 172.28.1.10 0.0.0.0 area 0
end

 

2. Configure automatic IPv6 6to4 tunnel on R2, R3 and R4
# R2
configure terminal
ipv6 unicast-routing
ipv6 cef
interface Tunnel0
no shutdown
ipv6 address 2002:ac1c:0102::1/64
tunnel source 172.28.1.2
tunnel mode ipv6ip 6to4
ipv6 route 2002::/16 Tunnel0
interface Loopback1
ipv6 address 2002:ac1c:0102:1000::1/128
interface FastEthernet0/0
no shutdown
ipv6 address 2001:DB8:172:2802::1/64
end

# R3
configure terminal
ipv6 unicast-routing
ipv6 cef
interface Tunnel0
no shutdown
ipv6 address 2002:ac1c:0106::1/64
tunnel source 172.28.1.6
tunnel mode ipv6ip 6to4
ipv6 route 2002::/16 Tunnel0
interface Loopback1
ipv6 address 2002:ac1c:0106:1000::1/128
interface FastEthernet0/0
no shutdown
ipv6 address 2001:DB8:172:2803::1/64
end

# R4
configure terminal
ipv6 unicast-routing
ipv6 cef
interface Tunnel0
no shutdown
ipv6 address 2002:ac1c:010a::1/64
tunnel source 172.28.1.10
tunnel mode ipv6ip 6to4
ipv6 route 2002::/16 Tunnel0
interface Loopback1
ipv6 address 2002:ac1c:010a:1000::1/128
interface FastEthernet0/0
no shutdown
ipv6 address 2001:DB8:172:2804::1/64
end

 

3. Configure IPv6 BGP peers between Loopback1 interfaces on R2, R3 and R4, and advertise FastEther0/0 IPv6 network
# R2
configure terminal
router bgp 65401
bgp router-id 172.28.1.2
bgp log-neighbor-changes
neighbor 2002:ac1c:0106:1000::1 remote-as 65401
neighbor 2002:ac1c:0106:1000::1 update-source Loopback1
neighbor 2002:ac1c:010a:1000::1 remote-as 65401
neighbor 2002:ac1c:010a:1000::1 update-source Loopback1
address-family ipv4
no neighbor 2002:ac1c:0106:1000::1 activate
no neighbor 2002:ac1c:010a:1000::1 activate
exit-address-family
address-family ipv6
network 2001:DB8:172:2802::1/64
neighbor 2002:ac1c:0106:1000::1 activate
neighbor 2002:ac1c:010a:1000::1 activate
exit-address-family
end
# R3
configure terminal
router bgp 65401
bgp router-id 172.28.1.6
bgp log-neighbor-changes
neighbor 2002:ac1c:0102:1000::1 remote-as 65401
neighbor 2002:ac1c:0102:1000::1 update-source Loopback1
neighbor 2002:ac1c:010a:1000::1 remote-as 65401
neighbor 2002:ac1c:010a:1000::1 update-source Loopback1
address-family ipv4
no neighbor 2002:ac1c:0102:1000::1 activate
no neighbor 2002:ac1c:010a:1000::1 activate
exit-address-family
address-family ipv6
network 2001:DB8:172:2803::1/64
neighbor 2002:ac1c:0102:1000::1 activate
neighbor 2002:ac1c:010a:1000::1 activate
exit-address-family
end
# R4
configure terminal
router bgp 65401
bgp router-id 172.28.1.10
bgp log-neighbor-changes
neighbor 2002:ac1c:0102:1000::1 remote-as 65401
neighbor 2002:ac1c:0102:1000::1 update-source Loopback1
neighbor 2002:ac1c:0106:1000::1 remote-as 65401
neighbor 2002:ac1c:0106:1000::1 update-source Loopback1
address-family ipv4
no neighbor 2002:ac1c:0102:1000::1 activate
no neighbor 2002:ac1c:0106:1000::1 activate
exit-address-family
address-family ipv6
network 2001:DB8:172:2804::1/64
neighbor 2002:ac1c:0102:1000::1 activate
neighbor 2002:ac1c:0106:1000::1 activate
exit-address-family
end

 

Posted in Routing and Switching | Tagged , , | Leave a comment

OSPF over Frame-Relay, configure OSPF over Frame-Relay point-to-point PVC

# OSPF over Frame-Relay, http://gns3vault.com/Frame-Relay/ospf-over-frame-relay.html
# TOPOLOGY
# There’re three routers connected to Frame-Relay cloud
# R14 is HUB, R15 and R16 are SPOKEN

# Objectives
# Configure OSPF over Frame-Relay point-to-point PVC

1. Create loopbacks on all routers:
R14: 172.28.0.14/32
R15: 172.28.0.15/32
R16: 172.28.0.16/32
2. Configure OSPF on all routers (172.28.64.32/29 subnet).
3. Advertise all loopbacks in OSPF.
4. R1 should be the OSPF designated router.

# r14
configure terminal
interface Loopback0
ip address 172.28.0.14 255.255.255.255
interface Serial1/0
encapsulation frame-relay
no arp frame-relay
no frame-relay inverse-arp
interface Serial1/0.514 point-to-point
ip address 172.28.64.33 255.255.255.252
frame-relay interface-dlci 514
interface Serial1/0.614 point-to-point
ip address 172.28.64.37 255.255.255.252
frame-relay interface-dlci 614
end

configure terminal
router ospf 100
router-id 172.28.0.14
log-adjacency-changes detail
network 172.28.0.14 0.0.0.0 area 0
network 172.28.64.33 0.0.0.0 area 0
network 172.28.64.37 0.0.0.0 area 0
end

# r15
configure terminal
interface Loopback0
ip address 172.28.0.15 255.255.255.255
interface Serial1/0
encapsulation frame-relay
no arp frame-relay
no frame-relay inverse-arp
interface Serial1/0.415 point-to-point
ip address 172.28.64.34 255.255.255.252
frame-relay interface-dlci 415
end

configure terminal
router ospf 100
router-id 172.28.0.15
log-adjacency-changes detail
network 172.28.0.15 0.0.0.0 area 0
network 172.28.64.34 0.0.0.0 area 0
end

# r16
configure terminal
interface Loopback0
ip address 172.28.0.16 255.255.255.255
interface Serial1/0
encapsulation frame-relay
no arp frame-relay
no frame-relay inverse-arp
interface Serial1/0.416 point-to-point
ip address 172.28.64.38 255.255.255.252
frame-relay interface-dlci 416
end

configure terminal
router ospf 100
router-id 172.28.0.16
log-adjacency-changes detail
network 172.28.0.16 0.0.0.0 area 0
network 172.28.64.32 0.0.0.7 area 0
end

# Verify if you have full connectivity.
#
show frame-relay map

show frame-relay pvc 514

show frame-relay pvc 614

show frame-relay pvc 415

show frame-relay pvc 416

show ip ospf neighbor

show ip route
# RESULT on R14
#
r14#show frame-relay map
Serial1/0.514 (up): point-to-point dlci, dlci 514(0x202,0x8020), broadcast
status defined, active
Serial1/0.614 (up): point-to-point dlci, dlci 614(0x266,0x9860), broadcast
status defined, active
r14#
r14#show frame-relay pvc 514

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 514, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.514

input pkts 27 output pkts 33 in bytes 3135
out bytes 3779 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 33 out bcast bytes 3779
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:02:56, last time pvc status changed 00:02:56
r14#
r14#show frame-relay pvc 614

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 614, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.614

input pkts 16 output pkts 29 in bytes 1982
out bytes 3407 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 29 out bcast bytes 3407
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:02:56, last time pvc status changed 00:02:56
r14#
r14#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
172.28.0.16 0 FULL/ – 00:00:39 172.28.64.38 Serial1/0.614
172.28.0.15 0 FULL/ – 00:00:32 172.28.64.34 Serial1/0.514
r14#
r14#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
+ – replicated route, % – next hop override

Gateway of last resort is not set

172.28.0.0/16 is variably subnetted, 7 subnets, 2 masks
C 172.28.0.14/32 is directly connected, Loopback0
O 172.28.0.15/32 [110/65] via 172.28.64.34, 00:02:14, Serial1/0.514
O 172.28.0.16/32 [110/65] via 172.28.64.38, 00:01:08, Serial1/0.614
C 172.28.64.32/30 is directly connected, Serial1/0.514
L 172.28.64.33/32 is directly connected, Serial1/0.514
C 172.28.64.36/30 is directly connected, Serial1/0.614
L 172.28.64.37/32 is directly connected, Serial1/0.614
r14#

# RESULT on R15
#
r15#show frame-relay map
Serial1/0.415 (up): point-to-point dlci, dlci 415(0x19F,0x64F0), broadcast
status defined, active
r15#
r15#show frame-relay pvc 415

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 415, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.415

input pkts 38 output pkts 33 in bytes 4500
out bytes 3936 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 33 out bcast bytes 3936
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:03:34, last time pvc status changed 00:03:34
r15#
r15#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
172.28.0.14 0 FULL/ – 00:00:32 172.28.64.33 Serial1/0.415
r15#
r15#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
+ – replicated route, % – next hop override

Gateway of last resort is not set

172.28.0.0/16 is variably subnetted, 6 subnets, 2 masks
O 172.28.0.14/32 [110/65] via 172.28.64.33, 00:03:11, Serial1/0.415
C 172.28.0.15/32 is directly connected, Loopback0
O 172.28.0.16/32 [110/129] via 172.28.64.33, 00:01:55, Serial1/0.415
C 172.28.64.32/30 is directly connected, Serial1/0.415
L 172.28.64.34/32 is directly connected, Serial1/0.415
O 172.28.64.36/30 [110/128] via 172.28.64.33, 00:03:11, Serial1/0.415
r15#

# RESULT on R16
#
r16#show frame-relay map
Serial1/0.416 (up): point-to-point dlci, dlci 416(0x1A0,0x6800), broadcast
status defined, active
r16#
r16#show frame-relay pvc 416

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 416, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.416

input pkts 34 output pkts 23 in bytes 3831
out bytes 2867 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 23 out bcast bytes 2867
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:03:32, last time pvc status changed 00:03:32
r16#
r16#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
172.28.0.14 0 FULL/ – 00:00:32 172.28.64.37 Serial1/0.416
r16#
r16#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
+ – replicated route, % – next hop override

Gateway of last resort is not set

172.28.0.0/16 is variably subnetted, 6 subnets, 2 masks
O 172.28.0.14/32 [110/65] via 172.28.64.37, 00:02:06, Serial1/0.416
O 172.28.0.15/32 [110/129] via 172.28.64.37, 00:02:06, Serial1/0.416
C 172.28.0.16/32 is directly connected, Loopback0
O 172.28.64.32/30 [110/128] via 172.28.64.37, 00:02:06, Serial1/0.416
C 172.28.64.36/30 is directly connected, Serial1/0.416
L 172.28.64.38/32 is directly connected, Serial1/0.416
r16#

Posted in Routing and Switching | Leave a comment

OSPF over Frame-Relay, Configure the OSPF network type on all routers to “Point-to-Multipoint non-broadcast”, ensure you still have full connectivity.

# OSPF over Frame-Relay, http://gns3vault.com/Frame-Relay/ospf-over-frame-relay.html
# TOPOLOGY
# There’re three routers connected to Frame-Relay cloud
# R11 is HUB, R12 and R13 are SPOKEN

# Objectives
# Configure the OSPF network type on all routers to “Point-to-Multipoint non-broadcast”, ensure you still have full connectivity.

1. Create loopbacks on all routers:
R11: 172.28.0.11/32
R12: 172.28.0.12/32
R13: 172.28.0.13/32
2. Configure OSPF on all routers (172.28.64.24/29 subnet).
3. Advertise all loopbacks in OSPF.
4. R1 should be the OSPF designated router.

# r11
configure terminal
interface Loopback0
ip address 172.28.0.11 255.255.255.255
interface Serial1/0
ip address 172.28.64.25 255.255.255.248
ip ospf priority 255
ip ospf network point-to-multipoint non-broadcast
encapsulation frame-relay
no arp frame-relay
no frame-relay inverse-arp
frame-relay map ip 172.28.64.26 211 broadcast
frame-relay map ip 172.28.64.27 311 broadcast
end

configure terminal
router ospf 100
router-id 172.28.0.11
log-adjacency-changes detail
network 172.28.0.11 0.0.0.0 area 0
network 172.28.64.24 0.0.0.7 area 0
neighbor 172.28.64.26
neighbor 172.28.64.27
end
# r12
configure terminal
interface Loopback0
ip address 172.28.0.12 255.255.255.255
interface Serial1/0
ip address 172.28.64.26 255.255.255.248
ip ospf network point-to-multipoint non-broadcast
encapsulation frame-relay
no arp frame-relay
no frame-relay inverse-arp
frame-relay map ip 172.28.64.25 112 broadcast
end

configure terminal
router ospf 100
router-id 172.28.0.12
log-adjacency-changes detail
network 172.28.0.12 0.0.0.0 area 0
network 172.28.64.24 0.0.0.7 area 0
end

# r13
configure terminal
interface Loopback0
ip address 172.28.0.13 255.255.255.255
interface Serial1/0
ip address 172.28.64.27 255.255.255.248
ip ospf network point-to-multipoint non-broadcast
encapsulation frame-relay
no arp frame-relay
no frame-relay inverse-arp
frame-relay map ip 172.28.64.25 113 broadcast
end

configure terminal
router ospf 100
router-id 172.28.0.13
log-adjacency-changes detail
network 172.28.0.13 0.0.0.0 area 0
network 172.28.64.24 0.0.0.7 area 0
end

# Verify if you have full connectivity.
#
show frame-relay map

show frame-relay pvc 211

show frame-relay pvc 311

show frame-relay pvc 112

show frame-relay pvc 113

show ip ospf neighbor

show ip route
# RESULT on R11
#
r11#show frame-relay map
Serial1/0 (up): ip 172.28.64.26 dlci 211(0xD3,0x3430), static,
broadcast,
CISCO, status defined, active
Serial1/0 (up): ip 172.28.64.27 dlci 311(0x137,0x4C70), static,
broadcast,
CISCO, status defined, active
r11#
r11#show frame-relay pvc 211

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 211, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 10 output pkts 13 in bytes 904
out bytes 1252 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:00:45, last time pvc status changed 00:00:25
r11#
r11#show frame-relay pvc 311

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 311, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 11 output pkts 14 in bytes 952
out bytes 1368 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:00:45, last time pvc status changed 00:00:25
r11#
r11#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
172.28.0.12 0 FULL/ – 00:01:45 172.28.64.26 Serial1/0
172.28.0.13 0 FULL/ – 00:01:50 172.28.64.27 Serial1/0
r11#
r11#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
+ – replicated route, % – next hop override

Gateway of last resort is not set

172.28.0.0/16 is variably subnetted, 7 subnets, 2 masks
C 172.28.0.11/32 is directly connected, Loopback0
O 172.28.0.12/32 [110/65] via 172.28.64.26, 00:00:12, Serial1/0
O 172.28.0.13/32 [110/65] via 172.28.64.27, 00:00:12, Serial1/0
C 172.28.64.24/29 is directly connected, Serial1/0
L 172.28.64.25/32 is directly connected, Serial1/0
O 172.28.64.26/32 [110/64] via 172.28.64.26, 00:00:12, Serial1/0
O 172.28.64.27/32 [110/64] via 172.28.64.27, 00:00:12, Serial1/0
r11#

# RESULT on R12
#
r12#show frame-relay map
Serial1/0 (up): ip 172.28.64.25 dlci 112(0x70,0x1C00), static,
broadcast,
CISCO, status defined, active
r12#
r12#show frame-relay pvc 112

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 112, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 14 output pkts 10 in bytes 1340
out bytes 876 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:01:00, last time pvc status changed 00:00:40
r12#
r12#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
172.28.0.11 0 FULL/ – 00:01:46 172.28.64.25 Serial1/0
r12#
r12#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
+ – replicated route, % – next hop override

Gateway of last resort is not set

172.28.0.0/16 is variably subnetted, 7 subnets, 2 masks
O 172.28.0.11/32 [110/65] via 172.28.64.25, 00:00:36, Serial1/0
C 172.28.0.12/32 is directly connected, Loopback0
O 172.28.0.13/32 [110/129] via 172.28.64.25, 00:00:36, Serial1/0
C 172.28.64.24/29 is directly connected, Serial1/0
O 172.28.64.25/32 [110/64] via 172.28.64.25, 00:00:36, Serial1/0
L 172.28.64.26/32 is directly connected, Serial1/0
O 172.28.64.27/32 [110/128] via 172.28.64.25, 00:00:36, Serial1/0
r12#

# RESULT on R13
#
r13#show frame-relay map
Serial1/0 (up): ip 172.28.64.25 dlci 113(0x71,0x1C10), static,
broadcast,
CISCO, status defined, active
r13#
r13#show frame-relay pvc 113

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 113, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 15 output pkts 11 in bytes 1456
out bytes 924 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:01:08, last time pvc status changed 00:00:48
r13#
r13#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
172.28.0.11 0 FULL/ – 00:01:50 172.28.64.25 Serial1/0
r13#
r13#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
+ – replicated route, % – next hop override

Gateway of last resort is not set

172.28.0.0/16 is variably subnetted, 7 subnets, 2 masks
O 172.28.0.11/32 [110/65] via 172.28.64.25, 00:00:32, Serial1/0
O 172.28.0.12/32 [110/129] via 172.28.64.25, 00:00:22, Serial1/0
C 172.28.0.13/32 is directly connected, Loopback0
C 172.28.64.24/29 is directly connected, Serial1/0
O 172.28.64.25/32 [110/64] via 172.28.64.25, 00:00:32, Serial1/0
O 172.28.64.26/32 [110/128] via 172.28.64.25, 00:00:22, Serial1/0
L 172.28.64.27/32 is directly connected, Serial1/0
r13#

Posted in Routing and Switching | Leave a comment

OSPF over Frame-Relay, Configure the OSPF network type on all routers to “Non-Broadcast”, ensure you still have full connectivity.

# OSPF over Frame-Relay, http://gns3vault.com/Frame-Relay/ospf-over-frame-relay.html
# TOPOLOGY
# There’re three routers connected to Frame-Relay cloud
# R7 is HUB, R8 and R9 are SPOKEN

# Objectives
# Configure the OSPF network type on all routers to “Non-Broadcast”, ensure you still have full connectivity.

1. Create loopbacks on all routers:
R7: 172.28.0.7/32
R8: 172.28.0.8/32
R9: 172.28.0.9/32
2. Configure OSPF on all routers (172.28.64.16/29 subnet).
3. Advertise all loopbacks in OSPF.
4. R1 should be the OSPF designated router.

# r7
configure terminal
interface Loopback0
ip address 172.28.0.7 255.255.255.255
interface Serial1/0
ip address 172.28.64.17 255.255.255.248
ip ospf priority 255
ip ospf network non-broadcast
encapsulation frame-relay
no arp frame-relay
no frame-relay inverse-arp
frame-relay map ip 172.28.64.18 807 broadcast
frame-relay map ip 172.28.64.19 907 broadcast
end

configure terminal
router ospf 100
router-id 172.28.0.7
log-adjacency-changes detail
network 172.28.0.7 0.0.0.0 area 0
network 172.28.64.16 0.0.0.7 area 0
neighbor 172.28.64.18
neighbor 172.28.64.19
end
# r8
configure terminal
interface Loopback0
ip address 172.28.0.8 255.255.255.255
interface Serial1/0
ip address 172.28.64.18 255.255.255.248
ip ospf network non-broadcast
encapsulation frame-relay
no arp frame-relay
no frame-relay inverse-arp
frame-relay map ip 172.28.64.17 708 broadcast
end

configure terminal
router ospf 100
router-id 172.28.0.8
log-adjacency-changes detail
network 172.28.0.8 0.0.0.0 area 0
network 172.28.64.16 0.0.0.7 area 0
neighbor 172.28.64.17
end

# r9
configure terminal
interface Loopback0
ip address 172.28.0.9 255.255.255.255
interface Serial1/0
ip address 172.28.64.19 255.255.255.248
ip ospf network non-broadcast
encapsulation frame-relay
no arp frame-relay
no frame-relay inverse-arp
frame-relay map ip 172.28.64.17 709 broadcast
end

configure terminal
router ospf 100
router-id 172.28.0.9
log-adjacency-changes detail
network 172.28.0.9 0.0.0.0 area 0
network 172.28.64.16 0.0.0.7 area 0
neighbor 172.28.64.17
end

# Verify if you have full connectivity.
#
show frame-relay map

show frame-relay pvc 807

show frame-relay pvc 907

show frame-relay pvc 708

show frame-relay pvc 709

show ip ospf neighbor

show ip route
# RESULT on R7
#
r7#show frame-relay map
Serial1/0 (up): ip 172.28.64.18 dlci 807(0x327,0xC870), static,
broadcast,
CISCO, status defined, active
Serial1/0 (up): ip 172.28.64.19 dlci 907(0x38B,0xE0B0), static,
broadcast,
CISCO, status defined, active
r7#
r7#show frame-relay pvc 807

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 807, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 13 output pkts 15 in bytes 1128
out bytes 1280 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:03:50, last time pvc status changed 00:03:50
r7#
r7#show frame-relay pvc 907

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 907, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 12 output pkts 12 in bytes 1032
out bytes 1120 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:03:50, last time pvc status changed 00:03:50
r7#
r7#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
172.28.0.8 1 FULL/DROTHER 00:01:53 172.28.64.18 Serial1/0
172.28.0.9 1 FULL/BDR 00:01:51 172.28.64.19 Serial1/0
r7#
r7#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
+ – replicated route, % – next hop override

Gateway of last resort is not set

172.28.0.0/16 is variably subnetted, 5 subnets, 2 masks
C 172.28.0.7/32 is directly connected, Loopback0
O 172.28.0.8/32 [110/65] via 172.28.64.18, 00:01:29, Serial1/0
O 172.28.0.9/32 [110/65] via 172.28.64.19, 00:01:19, Serial1/0
C 172.28.64.16/29 is directly connected, Serial1/0
L 172.28.64.17/32 is directly connected, Serial1/0
r7#

# RESULT on R8
#
r8#show frame-relay map
Serial1/0 (up): ip 172.28.64.17 dlci 708(0x2C4,0xB040), static,
broadcast,
CISCO, status defined, active
r8#
r8#show frame-relay pvc 708

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 708, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 16 output pkts 12 in bytes 1368
out bytes 1028 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:04:09, last time pvc status changed 00:03:49
r8#
r8#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
172.28.0.7 255 FULL/DR 00:01:35 172.28.64.17 Serial1/0
r8#
r8#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
+ – replicated route, % – next hop override

Gateway of last resort is not set

172.28.0.0/16 is variably subnetted, 5 subnets, 2 masks
O 172.28.0.7/32 [110/65] via 172.28.64.17, 00:01:51, Serial1/0
C 172.28.0.8/32 is directly connected, Loopback0
O 172.28.0.9/32 [110/65] via 172.28.64.19, 00:01:41, Serial1/0
C 172.28.64.16/29 is directly connected, Serial1/0
L 172.28.64.18/32 is directly connected, Serial1/0
r8#

# RESULT on R9
#
r9#show frame-relay map
Serial1/0 (up): ip 172.28.64.17 dlci 709(0x2C5,0xB050), static,
broadcast,
CISCO, status defined, active
r9#
r9#show frame-relay pvc 709

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 709, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 13 output pkts 12 in bytes 1208
out bytes 1032 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:04:12, last time pvc status changed 00:03:52
r9#
r9#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
172.28.0.7 255 FULL/DR 00:01:34 172.28.64.17 Serial1/0
r9#
r9#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
+ – replicated route, % – next hop override

Gateway of last resort is not set

172.28.0.0/16 is variably subnetted, 5 subnets, 2 masks
O 172.28.0.7/32 [110/65] via 172.28.64.17, 00:01:49, Serial1/0
O 172.28.0.8/32 [110/65] via 172.28.64.18, 00:01:49, Serial1/0
C 172.28.0.9/32 is directly connected, Loopback0
C 172.28.64.16/29 is directly connected, Serial1/0
L 172.28.64.19/32 is directly connected, Serial1/0
r9#

Posted in Routing and Switching | Leave a comment

OSPF over Frame-Relay, Configure the OSPF network type on all routers to “Broadcast”, ensure you have full connectivity to all subnets.

# OSPF over Frame-Relay, http://gns3vault.com/Frame-Relay/ospf-over-frame-relay.html
# TOPOLOGY
# There’re three routers connected to Frame-Relay cloud
# R4 is HUB, R5 and R6 are SPOKEN

# Objectives
# Configure the OSPF network type on all routers to “Broadcast”, ensure you have full connectivity to all subnets.

1. Create loopbacks on all routers:
R4: 172.28.0.4/32
R5: 172.28.0.5/32
R6: 172.28.0.6/32
2. Configure OSPF on all routers (172.28.64.8/29 subnet).
3. Advertise all loopbacks in OSPF.
4. R4 should be the OSPF designated router.

# r4
configure terminal
interface Loopback0
ip address 172.28.0.4 255.255.255.255
interface Serial1/0
encapsulation frame-relay
no arp frame-relay
no frame-relay inverse-arp
no shutdown
end

configure terminal
interface Serial1/0.405 multipoint
ip address 172.28.64.9 255.255.255.252
ip ospf priority 255
ip ospf network broadcast
frame-relay map ip 172.28.64.10 504 broadcast
end
configure terminal
interface Serial1/0.406 multipoint
ip address 172.28.64.13 255.255.255.252
ip ospf priority 255
ip ospf network broadcast
frame-relay map ip 172.28.64.14 604 broadcast
end

configure terminal
router ospf 100
router-id 172.28.0.4
log-adjacency-changes detail
network 172.28.0.4 0.0.0.0 area 0
network 172.28.64.8 0.0.0.7 area 0
end

# r5
configure terminal
interface Loopback0
ip address 172.28.0.5 255.255.255.255
interface Serial1/0
encapsulation frame-relay
no arp frame-relay
no frame-relay inverse-arp
no shutdown
ip address 172.28.64.10 255.255.255.252
ip ospf network broadcast
frame-relay map ip 172.28.64.9 405 broadcast
end

configure terminal
router ospf 100
router-id 172.28.0.5
log-adjacency-changes detail
network 172.28.0.5 0.0.0.0 area 0
network 172.28.64.8 0.0.0.7 area 0
end

# r6
configure terminal
interface Loopback0
ip address 172.28.0.6 255.255.255.255
interface Serial1/0
encapsulation frame-relay
no arp frame-relay
no frame-relay inverse-arp
no shutdown
ip address 172.28.64.14 255.255.255.252
ip ospf network broadcast
frame-relay map ip 172.28.64.13 406 broadcast
end

configure terminal
router ospf 100
router-id 172.28.0.6
log-adjacency-changes detail
network 172.28.0.6 0.0.0.0 area 0
network 172.28.64.8 0.0.0.7 area 0
end
# Verify if you have full connectivity.
#
show frame-relay map

show frame-relay pvc 504
show frame-relay pvc 604

show frame-relay pvc 405

show frame-relay pvc 406

show ip ospf neighbor

show ip route
# RESULT on R4
#
r4#show frame-relay map
Serial1/0.405 (up): ip 172.28.64.10 dlci 504(0x1F8,0x7C80), static,
broadcast,
CISCO, status defined, active
Serial1/0.406 (up): ip 172.28.64.14 dlci 604(0x25C,0x94C0), static,
broadcast,
CISCO, status defined, active
r4#
r4#show frame-relay pvc 504

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 504, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.405

input pkts 109 output pkts 112 in bytes 9388
out bytes 9784 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 84 out bcast bytes 7308
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:10:47, last time pvc status changed 00:10:47
r4#show frame-relay pvc 604

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 604, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.406

input pkts 42 output pkts 82 in bytes 3572
out bytes 6820 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 70 out bcast bytes 5836
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:10:47, last time pvc status changed 00:05:17
r4#
r4#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
172.28.0.6 1 FULL/BDR 00:00:32 172.28.64.14 Serial1/0.406
172.28.0.5 1 FULL/BDR 00:00:30 172.28.64.10 Serial1/0.405
r4#
r4#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
+ – replicated route, % – next hop override

Gateway of last resort is not set

172.28.0.0/16 is variably subnetted, 7 subnets, 2 masks
C 172.28.0.4/32 is directly connected, Loopback0
O 172.28.0.5/32 [110/65] via 172.28.64.10, 00:02:25, Serial1/0.405
O 172.28.0.6/32 [110/65] via 172.28.64.14, 00:02:25, Serial1/0.406
C 172.28.64.8/30 is directly connected, Serial1/0.405
L 172.28.64.9/32 is directly connected, Serial1/0.405
C 172.28.64.12/30 is directly connected, Serial1/0.406
L 172.28.64.13/32 is directly connected, Serial1/0.406
r4#

# RESULT on R5
#
r5#show frame-relay map
Serial1/0 (up): ip 172.28.64.9 dlci 405(0x195,0x6450), static,
broadcast,
CISCO, status defined, active
r5#
r5#show frame-relay pvc 405

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 405, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 77 output pkts 74 in bytes 6644
out bytes 6208 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 64 out bcast bytes 5388
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:08:23, last time pvc status changed 00:08:23
r5#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
172.28.0.4 255 FULL/DR 00:00:30 172.28.64.9 Serial1/0
r5#
r5#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
+ – replicated route, % – next hop override

Gateway of last resort is not set

172.28.0.0/16 is variably subnetted, 6 subnets, 2 masks
O 172.28.0.4/32 [110/65] via 172.28.64.9, 00:02:06, Serial1/0
C 172.28.0.5/32 is directly connected, Loopback0
O 172.28.0.6/32 [110/129] via 172.28.64.9, 00:01:56, Serial1/0
C 172.28.64.8/30 is directly connected, Serial1/0
L 172.28.64.10/32 is directly connected, Serial1/0
O 172.28.64.12/30 [110/128] via 172.28.64.9, 00:04:48, Serial1/0
r5#

# RESULT on R4
#
r6#show frame-relay map
Serial1/0 (up): ip 172.28.64.13 dlci 406(0x196,0x6460), static,
broadcast,
CISCO, status defined, active
r6#
r6#show frame-relay pvc 406

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 406, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 45 output pkts 34 in bytes 3828
out bytes 2900 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 28 out bcast bytes 2420
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:04:21, last time pvc status changed 00:04:21
r6#
r6#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
172.28.0.4 255 FULL/DR 00:00:37 172.28.64.13 Serial1/0
r6#
r6#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
+ – replicated route, % – next hop override

Gateway of last resort is not set

172.28.0.0/16 is variably subnetted, 6 subnets, 2 masks
O 172.28.0.4/32 [110/65] via 172.28.64.13, 00:01:22, Serial1/0
O 172.28.0.5/32 [110/129] via 172.28.64.13, 00:01:12, Serial1/0
C 172.28.0.6/32 is directly connected, Loopback0
O 172.28.64.8/30 [110/128] via 172.28.64.13, 00:02:54, Serial1/0
C 172.28.64.12/30 is directly connected, Serial1/0
L 172.28.64.14/32 is directly connected, Serial1/0
r6#

Posted in Routing and Switching | Leave a comment