OSPF over Frame-Relay, Configure the OSPF network type on all routers to “Point-to-Multipoint non-broadcast”, ensure you still have full connectivity.

# OSPF over Frame-Relay, http://gns3vault.com/Frame-Relay/ospf-over-frame-relay.html
# TOPOLOGY
# There’re three routers connected to Frame-Relay cloud
# R11 is HUB, R12 and R13 are SPOKEN

# Objectives
# Configure the OSPF network type on all routers to “Point-to-Multipoint non-broadcast”, ensure you still have full connectivity.

1. Create loopbacks on all routers:
R11: 172.28.0.11/32
R12: 172.28.0.12/32
R13: 172.28.0.13/32
2. Configure OSPF on all routers (172.28.64.24/29 subnet).
3. Advertise all loopbacks in OSPF.
4. R1 should be the OSPF designated router.

# r11
configure terminal
interface Loopback0
ip address 172.28.0.11 255.255.255.255
interface Serial1/0
ip address 172.28.64.25 255.255.255.248
ip ospf priority 255
ip ospf network point-to-multipoint non-broadcast
encapsulation frame-relay
no arp frame-relay
no frame-relay inverse-arp
frame-relay map ip 172.28.64.26 211 broadcast
frame-relay map ip 172.28.64.27 311 broadcast
end

configure terminal
router ospf 100
router-id 172.28.0.11
log-adjacency-changes detail
network 172.28.0.11 0.0.0.0 area 0
network 172.28.64.24 0.0.0.7 area 0
neighbor 172.28.64.26
neighbor 172.28.64.27
end
# r12
configure terminal
interface Loopback0
ip address 172.28.0.12 255.255.255.255
interface Serial1/0
ip address 172.28.64.26 255.255.255.248
ip ospf network point-to-multipoint non-broadcast
encapsulation frame-relay
no arp frame-relay
no frame-relay inverse-arp
frame-relay map ip 172.28.64.25 112 broadcast
end

configure terminal
router ospf 100
router-id 172.28.0.12
log-adjacency-changes detail
network 172.28.0.12 0.0.0.0 area 0
network 172.28.64.24 0.0.0.7 area 0
end

# r13
configure terminal
interface Loopback0
ip address 172.28.0.13 255.255.255.255
interface Serial1/0
ip address 172.28.64.27 255.255.255.248
ip ospf network point-to-multipoint non-broadcast
encapsulation frame-relay
no arp frame-relay
no frame-relay inverse-arp
frame-relay map ip 172.28.64.25 113 broadcast
end

configure terminal
router ospf 100
router-id 172.28.0.13
log-adjacency-changes detail
network 172.28.0.13 0.0.0.0 area 0
network 172.28.64.24 0.0.0.7 area 0
end

# Verify if you have full connectivity.
#
show frame-relay map

show frame-relay pvc 211

show frame-relay pvc 311

show frame-relay pvc 112

show frame-relay pvc 113

show ip ospf neighbor

show ip route
# RESULT on R11
#
r11#show frame-relay map
Serial1/0 (up): ip 172.28.64.26 dlci 211(0xD3,0x3430), static,
broadcast,
CISCO, status defined, active
Serial1/0 (up): ip 172.28.64.27 dlci 311(0x137,0x4C70), static,
broadcast,
CISCO, status defined, active
r11#
r11#show frame-relay pvc 211

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 211, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 10 output pkts 13 in bytes 904
out bytes 1252 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:00:45, last time pvc status changed 00:00:25
r11#
r11#show frame-relay pvc 311

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 311, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 11 output pkts 14 in bytes 952
out bytes 1368 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:00:45, last time pvc status changed 00:00:25
r11#
r11#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
172.28.0.12 0 FULL/ – 00:01:45 172.28.64.26 Serial1/0
172.28.0.13 0 FULL/ – 00:01:50 172.28.64.27 Serial1/0
r11#
r11#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
+ – replicated route, % – next hop override

Gateway of last resort is not set

172.28.0.0/16 is variably subnetted, 7 subnets, 2 masks
C 172.28.0.11/32 is directly connected, Loopback0
O 172.28.0.12/32 [110/65] via 172.28.64.26, 00:00:12, Serial1/0
O 172.28.0.13/32 [110/65] via 172.28.64.27, 00:00:12, Serial1/0
C 172.28.64.24/29 is directly connected, Serial1/0
L 172.28.64.25/32 is directly connected, Serial1/0
O 172.28.64.26/32 [110/64] via 172.28.64.26, 00:00:12, Serial1/0
O 172.28.64.27/32 [110/64] via 172.28.64.27, 00:00:12, Serial1/0
r11#

# RESULT on R12
#
r12#show frame-relay map
Serial1/0 (up): ip 172.28.64.25 dlci 112(0x70,0x1C00), static,
broadcast,
CISCO, status defined, active
r12#
r12#show frame-relay pvc 112

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 112, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 14 output pkts 10 in bytes 1340
out bytes 876 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:01:00, last time pvc status changed 00:00:40
r12#
r12#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
172.28.0.11 0 FULL/ – 00:01:46 172.28.64.25 Serial1/0
r12#
r12#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
+ – replicated route, % – next hop override

Gateway of last resort is not set

172.28.0.0/16 is variably subnetted, 7 subnets, 2 masks
O 172.28.0.11/32 [110/65] via 172.28.64.25, 00:00:36, Serial1/0
C 172.28.0.12/32 is directly connected, Loopback0
O 172.28.0.13/32 [110/129] via 172.28.64.25, 00:00:36, Serial1/0
C 172.28.64.24/29 is directly connected, Serial1/0
O 172.28.64.25/32 [110/64] via 172.28.64.25, 00:00:36, Serial1/0
L 172.28.64.26/32 is directly connected, Serial1/0
O 172.28.64.27/32 [110/128] via 172.28.64.25, 00:00:36, Serial1/0
r12#

# RESULT on R13
#
r13#show frame-relay map
Serial1/0 (up): ip 172.28.64.25 dlci 113(0x71,0x1C10), static,
broadcast,
CISCO, status defined, active
r13#
r13#show frame-relay pvc 113

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 113, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 15 output pkts 11 in bytes 1456
out bytes 924 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:01:08, last time pvc status changed 00:00:48
r13#
r13#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
172.28.0.11 0 FULL/ – 00:01:50 172.28.64.25 Serial1/0
r13#
r13#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
+ – replicated route, % – next hop override

Gateway of last resort is not set

172.28.0.0/16 is variably subnetted, 7 subnets, 2 masks
O 172.28.0.11/32 [110/65] via 172.28.64.25, 00:00:32, Serial1/0
O 172.28.0.12/32 [110/129] via 172.28.64.25, 00:00:22, Serial1/0
C 172.28.0.13/32 is directly connected, Loopback0
C 172.28.64.24/29 is directly connected, Serial1/0
O 172.28.64.25/32 [110/64] via 172.28.64.25, 00:00:32, Serial1/0
O 172.28.64.26/32 [110/128] via 172.28.64.25, 00:00:22, Serial1/0
L 172.28.64.27/32 is directly connected, Serial1/0
r13#

Advertisements
This entry was posted in Routing and Switching. Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s