OSPF over Frame-Relay, configure the OSPF network type on all routers to “Point-to-Multipoint”, ensure you still have full connectivity.

# OSPF over Frame-Relay, http://gns3vault.com/Frame-Relay/ospf-over-frame-relay.html
# TOPOLOGY
# There’re three routers connected to Frame-Relay cloud
# R1 is HUB, R2 and R3 are SPOKEN

# Objectives
# Configure the OSPF network type on all routers to “Point-to-Multipoint”, ensure you still have full connectivity.

1. Create loopbacks on all routers:
R1: 172.28.0.1/32
R2: 172.28.0.2/32
R3: 172.28.0.3/32
2. Configure OSPF on all routers (172.28.64.0/29 subnet).
3. Advertise all loopbacks in OSPF.
4. R1 should be the OSPF designated router.

# r1
configure terminal
interface Loopback0
ip address 172.28.0.1 255.255.255.255
interface Serial1/0
ip address 172.28.64.1 255.255.255.248
ip ospf priority 255
ip ospf network point-to-multipoint
encapsulation frame-relay
no arp frame-relay
no frame-relay inverse-arp
frame-relay map ip 172.28.64.2 201 broadcast
frame-relay map ip 172.28.64.3 301 broadcast

router ospf 100
router-id 172.28.0.1
log-adjacency-changes detail
network 172.28.0.1 0.0.0.0 area 0
network 172.28.64.0 0.0.0.7 area 0
end
# r2
configure terminal
interface Loopback0
ip address 172.28.0.2 255.255.255.255
interface Serial1/0
ip address 172.28.64.2 255.255.255.248
ip ospf network point-to-multipoint
encapsulation frame-relay
no arp frame-relay
no frame-relay inverse-arp
frame-relay map ip 172.28.64.1 102 broadcast

router ospf 100
router-id 172.28.0.2
log-adjacency-changes detail
network 172.28.0.2 0.0.0.0 area 0
network 172.28.64.0 0.0.0.7 area 0
end

# r3
configure terminal
interface Loopback0
ip address 172.28.0.3 255.255.255.255
interface Serial1/0
ip address 172.28.64.3 255.255.255.248
ip ospf network point-to-multipoint
encapsulation frame-relay
no arp frame-relay
no frame-relay inverse-arp
frame-relay map ip 172.28.64.1 103 broadcast

router ospf 100
router-id 172.28.0.3
log-adjacency-changes detail
network 172.28.0.3 0.0.0.0 area 0
network 172.28.64.0 0.0.0.7 area 0
end

# Verify if you have full connectivity.
#
show frame-relay map

show frame-relay pvc 201
show frame-relay pvc 301

show frame-relay pvc 102

show frame-relay pvc 103

show ip ospf neighbor

show ip route
# RESULT on R1
#
r1#show frame-relay map
Serial1/0 (up): ip 172.28.64.3 dlci 301(0x12D,0x48D0), static,
broadcast,
CISCO, status defined, active
Serial1/0 (up): ip 172.28.64.2 dlci 201(0xC9,0x3090), static,
broadcast,
CISCO, status defined, active
r1#
r1#show frame-relay pvc 201

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 201, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 13 output pkts 19 in bytes 1076
out bytes 1636 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 6 out bcast bytes 508
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 16:18:27, last time pvc status changed 16:18:19
r1#show frame-relay pvc 301

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 301, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 13 output pkts 17 in bytes 1108
out bytes 1572 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 6 out bcast bytes 508
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:22:16, last time pvc status changed 00:21:26
r1#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
172.28.0.3 0 FULL/ – 00:01:59 172.28.64.3 Serial1/0
172.28.0.2 0 FULL/ – 00:01:32 172.28.64.2 Serial1/0
r1#
r1#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
+ – replicated route, % – next hop override

Gateway of last resort is not set

172.28.0.0/16 is variably subnetted, 7 subnets, 2 masks
C 172.28.0.1/32 is directly connected, Loopback0
O 172.28.0.2/32 [110/65] via 172.28.64.2, 00:01:45, Serial1/0
O 172.28.0.3/32 [110/65] via 172.28.64.3, 00:01:16, Serial1/0
C 172.28.64.0/29 is directly connected, Serial1/0
L 172.28.64.1/32 is directly connected, Serial1/0
O 172.28.64.2/32 [110/64] via 172.28.64.2, 00:01:55, Serial1/0
O 172.28.64.3/32 [110/64] via 172.28.64.3, 00:01:26, Serial1/0

# RESULT on R2
#
r2#show frame-relay map
Serial1/0 (up): ip 172.28.64.1 dlci 102(0x66,0x1860), static,
broadcast,
CISCO, status defined, active
r2#show frame-relay pvc 102

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 24 output pkts 18 in bytes 2076
out bytes 1516 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 9 out bcast bytes 780
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 16:20:40, last time pvc status changed 16:20:22
r2#
r2#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
172.28.0.3 0 INIT/ – 00:01:33 172.28.64.3 Serial1/0
172.28.0.1 0 FULL/ – 00:01:50 172.28.64.1 Serial1/0
r2#
r2#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
+ – replicated route, % – next hop override

Gateway of last resort is not set

172.28.0.0/16 is variably subnetted, 7 subnets, 2 masks
O 172.28.0.1/32 [110/65] via 172.28.64.1, 00:04:06, Serial1/0
C 172.28.0.2/32 is directly connected, Loopback0
O 172.28.0.3/32 [110/129] via 172.28.64.1, 00:03:27, Serial1/0
C 172.28.64.0/29 is directly connected, Serial1/0
O 172.28.64.1/32 [110/64] via 172.28.64.1, 00:04:06, Serial1/0
L 172.28.64.2/32 is directly connected, Serial1/0
O 172.28.64.3/32 [110/128] via 172.28.64.1, 00:03:37, Serial1/0
r2#

# RESULT on R3
#
r3#show frame-relay map
Serial1/0 (up): ip 172.28.64.1 dlci 103(0x67,0x1870), static,
broadcast,
CISCO, status defined, active
r3#show frame-relay pvc 103

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 103, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 9 output pkts 13 in bytes 876
out bytes 1220 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 1 out bcast bytes 80
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:00:28, last time pvc status changed 00:00:28
r3#
r3#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
172.28.0.1 0 FULL/ – 00:01:58 172.28.64.1 Serial1/0
r3#
r3#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
+ – replicated route, % – next hop override

Gateway of last resort is not set

172.28.0.0/16 is variably subnetted, 7 subnets, 2 masks
O 172.28.0.1/32 [110/65] via 172.28.64.1, 00:00:23, Serial1/0
O 172.28.0.2/32 [110/129] via 172.28.64.1, 00:00:23, Serial1/0
C 172.28.0.3/32 is directly connected, Loopback0
C 172.28.64.0/29 is directly connected, Serial1/0
O 172.28.64.1/32 [110/64] via 172.28.64.1, 00:00:23, Serial1/0
O 172.28.64.2/32 [110/128] via 172.28.64.1, 00:00:23, Serial1/0
L 172.28.64.3/32 is directly connected, Serial1/0
r3#

Advertisements
This entry was posted in Routing and Switching. Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s