OSPF over Frame-Relay, Configure the OSPF network type on all routers to “Non-Broadcast”, ensure you still have full connectivity.

# OSPF over Frame-Relay, http://gns3vault.com/Frame-Relay/ospf-over-frame-relay.html
# TOPOLOGY
# There’re three routers connected to Frame-Relay cloud
# R7 is HUB, R8 and R9 are SPOKEN

# Objectives
# Configure the OSPF network type on all routers to “Non-Broadcast”, ensure you still have full connectivity.

1. Create loopbacks on all routers:
R7: 172.28.0.7/32
R8: 172.28.0.8/32
R9: 172.28.0.9/32
2. Configure OSPF on all routers (172.28.64.16/29 subnet).
3. Advertise all loopbacks in OSPF.
4. R1 should be the OSPF designated router.

# r7
configure terminal
interface Loopback0
ip address 172.28.0.7 255.255.255.255
interface Serial1/0
ip address 172.28.64.17 255.255.255.248
ip ospf priority 255
ip ospf network non-broadcast
encapsulation frame-relay
no arp frame-relay
no frame-relay inverse-arp
frame-relay map ip 172.28.64.18 807 broadcast
frame-relay map ip 172.28.64.19 907 broadcast
end

configure terminal
router ospf 100
router-id 172.28.0.7
log-adjacency-changes detail
network 172.28.0.7 0.0.0.0 area 0
network 172.28.64.16 0.0.0.7 area 0
neighbor 172.28.64.18
neighbor 172.28.64.19
end
# r8
configure terminal
interface Loopback0
ip address 172.28.0.8 255.255.255.255
interface Serial1/0
ip address 172.28.64.18 255.255.255.248
ip ospf network non-broadcast
encapsulation frame-relay
no arp frame-relay
no frame-relay inverse-arp
frame-relay map ip 172.28.64.17 708 broadcast
end

configure terminal
router ospf 100
router-id 172.28.0.8
log-adjacency-changes detail
network 172.28.0.8 0.0.0.0 area 0
network 172.28.64.16 0.0.0.7 area 0
neighbor 172.28.64.17
end

# r9
configure terminal
interface Loopback0
ip address 172.28.0.9 255.255.255.255
interface Serial1/0
ip address 172.28.64.19 255.255.255.248
ip ospf network non-broadcast
encapsulation frame-relay
no arp frame-relay
no frame-relay inverse-arp
frame-relay map ip 172.28.64.17 709 broadcast
end

configure terminal
router ospf 100
router-id 172.28.0.9
log-adjacency-changes detail
network 172.28.0.9 0.0.0.0 area 0
network 172.28.64.16 0.0.0.7 area 0
neighbor 172.28.64.17
end

# Verify if you have full connectivity.
#
show frame-relay map

show frame-relay pvc 807

show frame-relay pvc 907

show frame-relay pvc 708

show frame-relay pvc 709

show ip ospf neighbor

show ip route
# RESULT on R7
#
r7#show frame-relay map
Serial1/0 (up): ip 172.28.64.18 dlci 807(0x327,0xC870), static,
broadcast,
CISCO, status defined, active
Serial1/0 (up): ip 172.28.64.19 dlci 907(0x38B,0xE0B0), static,
broadcast,
CISCO, status defined, active
r7#
r7#show frame-relay pvc 807

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 807, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 13 output pkts 15 in bytes 1128
out bytes 1280 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:03:50, last time pvc status changed 00:03:50
r7#
r7#show frame-relay pvc 907

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 907, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 12 output pkts 12 in bytes 1032
out bytes 1120 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:03:50, last time pvc status changed 00:03:50
r7#
r7#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
172.28.0.8 1 FULL/DROTHER 00:01:53 172.28.64.18 Serial1/0
172.28.0.9 1 FULL/BDR 00:01:51 172.28.64.19 Serial1/0
r7#
r7#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
+ – replicated route, % – next hop override

Gateway of last resort is not set

172.28.0.0/16 is variably subnetted, 5 subnets, 2 masks
C 172.28.0.7/32 is directly connected, Loopback0
O 172.28.0.8/32 [110/65] via 172.28.64.18, 00:01:29, Serial1/0
O 172.28.0.9/32 [110/65] via 172.28.64.19, 00:01:19, Serial1/0
C 172.28.64.16/29 is directly connected, Serial1/0
L 172.28.64.17/32 is directly connected, Serial1/0
r7#

# RESULT on R8
#
r8#show frame-relay map
Serial1/0 (up): ip 172.28.64.17 dlci 708(0x2C4,0xB040), static,
broadcast,
CISCO, status defined, active
r8#
r8#show frame-relay pvc 708

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 708, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 16 output pkts 12 in bytes 1368
out bytes 1028 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:04:09, last time pvc status changed 00:03:49
r8#
r8#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
172.28.0.7 255 FULL/DR 00:01:35 172.28.64.17 Serial1/0
r8#
r8#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
+ – replicated route, % – next hop override

Gateway of last resort is not set

172.28.0.0/16 is variably subnetted, 5 subnets, 2 masks
O 172.28.0.7/32 [110/65] via 172.28.64.17, 00:01:51, Serial1/0
C 172.28.0.8/32 is directly connected, Loopback0
O 172.28.0.9/32 [110/65] via 172.28.64.19, 00:01:41, Serial1/0
C 172.28.64.16/29 is directly connected, Serial1/0
L 172.28.64.18/32 is directly connected, Serial1/0
r8#

# RESULT on R9
#
r9#show frame-relay map
Serial1/0 (up): ip 172.28.64.17 dlci 709(0x2C5,0xB050), static,
broadcast,
CISCO, status defined, active
r9#
r9#show frame-relay pvc 709

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 709, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 13 output pkts 12 in bytes 1208
out bytes 1032 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:04:12, last time pvc status changed 00:03:52
r9#
r9#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
172.28.0.7 255 FULL/DR 00:01:34 172.28.64.17 Serial1/0
r9#
r9#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
+ – replicated route, % – next hop override

Gateway of last resort is not set

172.28.0.0/16 is variably subnetted, 5 subnets, 2 masks
O 172.28.0.7/32 [110/65] via 172.28.64.17, 00:01:49, Serial1/0
O 172.28.0.8/32 [110/65] via 172.28.64.18, 00:01:49, Serial1/0
C 172.28.0.9/32 is directly connected, Loopback0
C 172.28.64.16/29 is directly connected, Serial1/0
L 172.28.64.19/32 is directly connected, Serial1/0
r9#

Advertisements
This entry was posted in Routing and Switching. Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s