OSPF over Frame-Relay, Configure the OSPF network type on all routers to “Broadcast”, ensure you have full connectivity to all subnets.

# OSPF over Frame-Relay, http://gns3vault.com/Frame-Relay/ospf-over-frame-relay.html
# TOPOLOGY
# There’re three routers connected to Frame-Relay cloud
# R4 is HUB, R5 and R6 are SPOKEN

# Objectives
# Configure the OSPF network type on all routers to “Broadcast”, ensure you have full connectivity to all subnets.

1. Create loopbacks on all routers:
R4: 172.28.0.4/32
R5: 172.28.0.5/32
R6: 172.28.0.6/32
2. Configure OSPF on all routers (172.28.64.8/29 subnet).
3. Advertise all loopbacks in OSPF.
4. R4 should be the OSPF designated router.

# r4
configure terminal
interface Loopback0
ip address 172.28.0.4 255.255.255.255
interface Serial1/0
encapsulation frame-relay
no arp frame-relay
no frame-relay inverse-arp
no shutdown
end

configure terminal
interface Serial1/0.405 multipoint
ip address 172.28.64.9 255.255.255.252
ip ospf priority 255
ip ospf network broadcast
frame-relay map ip 172.28.64.10 504 broadcast
end
configure terminal
interface Serial1/0.406 multipoint
ip address 172.28.64.13 255.255.255.252
ip ospf priority 255
ip ospf network broadcast
frame-relay map ip 172.28.64.14 604 broadcast
end

configure terminal
router ospf 100
router-id 172.28.0.4
log-adjacency-changes detail
network 172.28.0.4 0.0.0.0 area 0
network 172.28.64.8 0.0.0.7 area 0
end

# r5
configure terminal
interface Loopback0
ip address 172.28.0.5 255.255.255.255
interface Serial1/0
encapsulation frame-relay
no arp frame-relay
no frame-relay inverse-arp
no shutdown
ip address 172.28.64.10 255.255.255.252
ip ospf network broadcast
frame-relay map ip 172.28.64.9 405 broadcast
end

configure terminal
router ospf 100
router-id 172.28.0.5
log-adjacency-changes detail
network 172.28.0.5 0.0.0.0 area 0
network 172.28.64.8 0.0.0.7 area 0
end

# r6
configure terminal
interface Loopback0
ip address 172.28.0.6 255.255.255.255
interface Serial1/0
encapsulation frame-relay
no arp frame-relay
no frame-relay inverse-arp
no shutdown
ip address 172.28.64.14 255.255.255.252
ip ospf network broadcast
frame-relay map ip 172.28.64.13 406 broadcast
end

configure terminal
router ospf 100
router-id 172.28.0.6
log-adjacency-changes detail
network 172.28.0.6 0.0.0.0 area 0
network 172.28.64.8 0.0.0.7 area 0
end
# Verify if you have full connectivity.
#
show frame-relay map

show frame-relay pvc 504
show frame-relay pvc 604

show frame-relay pvc 405

show frame-relay pvc 406

show ip ospf neighbor

show ip route
# RESULT on R4
#
r4#show frame-relay map
Serial1/0.405 (up): ip 172.28.64.10 dlci 504(0x1F8,0x7C80), static,
broadcast,
CISCO, status defined, active
Serial1/0.406 (up): ip 172.28.64.14 dlci 604(0x25C,0x94C0), static,
broadcast,
CISCO, status defined, active
r4#
r4#show frame-relay pvc 504

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 504, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.405

input pkts 109 output pkts 112 in bytes 9388
out bytes 9784 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 84 out bcast bytes 7308
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:10:47, last time pvc status changed 00:10:47
r4#show frame-relay pvc 604

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 604, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.406

input pkts 42 output pkts 82 in bytes 3572
out bytes 6820 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 70 out bcast bytes 5836
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:10:47, last time pvc status changed 00:05:17
r4#
r4#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
172.28.0.6 1 FULL/BDR 00:00:32 172.28.64.14 Serial1/0.406
172.28.0.5 1 FULL/BDR 00:00:30 172.28.64.10 Serial1/0.405
r4#
r4#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
+ – replicated route, % – next hop override

Gateway of last resort is not set

172.28.0.0/16 is variably subnetted, 7 subnets, 2 masks
C 172.28.0.4/32 is directly connected, Loopback0
O 172.28.0.5/32 [110/65] via 172.28.64.10, 00:02:25, Serial1/0.405
O 172.28.0.6/32 [110/65] via 172.28.64.14, 00:02:25, Serial1/0.406
C 172.28.64.8/30 is directly connected, Serial1/0.405
L 172.28.64.9/32 is directly connected, Serial1/0.405
C 172.28.64.12/30 is directly connected, Serial1/0.406
L 172.28.64.13/32 is directly connected, Serial1/0.406
r4#

# RESULT on R5
#
r5#show frame-relay map
Serial1/0 (up): ip 172.28.64.9 dlci 405(0x195,0x6450), static,
broadcast,
CISCO, status defined, active
r5#
r5#show frame-relay pvc 405

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 405, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 77 output pkts 74 in bytes 6644
out bytes 6208 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 64 out bcast bytes 5388
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:08:23, last time pvc status changed 00:08:23
r5#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
172.28.0.4 255 FULL/DR 00:00:30 172.28.64.9 Serial1/0
r5#
r5#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
+ – replicated route, % – next hop override

Gateway of last resort is not set

172.28.0.0/16 is variably subnetted, 6 subnets, 2 masks
O 172.28.0.4/32 [110/65] via 172.28.64.9, 00:02:06, Serial1/0
C 172.28.0.5/32 is directly connected, Loopback0
O 172.28.0.6/32 [110/129] via 172.28.64.9, 00:01:56, Serial1/0
C 172.28.64.8/30 is directly connected, Serial1/0
L 172.28.64.10/32 is directly connected, Serial1/0
O 172.28.64.12/30 [110/128] via 172.28.64.9, 00:04:48, Serial1/0
r5#

# RESULT on R4
#
r6#show frame-relay map
Serial1/0 (up): ip 172.28.64.13 dlci 406(0x196,0x6460), static,
broadcast,
CISCO, status defined, active
r6#
r6#show frame-relay pvc 406

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

DLCI = 406, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 45 output pkts 34 in bytes 3828
out bytes 2900 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 28 out bcast bytes 2420
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:04:21, last time pvc status changed 00:04:21
r6#
r6#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
172.28.0.4 255 FULL/DR 00:00:37 172.28.64.13 Serial1/0
r6#
r6#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
+ – replicated route, % – next hop override

Gateway of last resort is not set

172.28.0.0/16 is variably subnetted, 6 subnets, 2 masks
O 172.28.0.4/32 [110/65] via 172.28.64.13, 00:01:22, Serial1/0
O 172.28.0.5/32 [110/129] via 172.28.64.13, 00:01:12, Serial1/0
C 172.28.0.6/32 is directly connected, Loopback0
O 172.28.64.8/30 [110/128] via 172.28.64.13, 00:02:54, Serial1/0
C 172.28.64.12/30 is directly connected, Serial1/0
L 172.28.64.14/32 is directly connected, Serial1/0
r6#

Advertisements
This entry was posted in Routing and Switching. Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s